Как написать программу в pascal в строчку, которая выводит разряды числа 12321? )

mashacat763p01bj9 mashacat763p01bj9    1   14.10.2019 08:34    11

Ответы
Милана2345 Милана2345  10.10.2020 06:42

program Example2;

var

 a, i: Integer;

begin

 Write ('Введете целое число: ');

 ReadLn (a);

 WriteLn;

 Write ('Разряды числа: ');

 while a > 0 do begin

   Write (a mod 10, ' ');

   a := a div 10;

 end;

 ReadLn;

end.

Объяснение:

mod -  выделяем последнюю цифру

div - отбрасываем последнюю цифру

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика