Как написать программу для вычисления наибольшего общего делителя? на языку с.

bigmama2 bigmama2    1   02.10.2019 07:01    5

Ответы
vkakochka vkakochka  27.08.2020 11:29

#include <stdio.h>

int main() {

   unsigned long a, b;

   scanf("%lu%lu", &a, &b);

   while(a && b) {

       if(a>b)

           a %= b;

       if(b>a)

           b %= a;

   }

   printf("%lu", a | b);

}


Решение по алгоритму Евклида.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика