Как много смыслов в простом пожелании! Напишите программу, которая найдет все строки, в которых есть что-то доброе (достаточно проверить наличие подстроки добр), а потом выберет из них строку с наименьшей длиной. Формат ввода

Вводятся строки, пока не будет введена строка с фамилией Бэггинс.

Формат вывода

Вывести наименьшую длину строки, в которой есть что-то доброе. Если таких не оказалось, вывести 0.Торопиться некуда таким добрым утром, целый день впереди!

От них одно беспокойство и неприятности!

Еще, чего доброго, пообедать из-за них опоздаешь!

Не понимаю, что в них находят доброго.

— Доброго утра вам!

Мы тут в приключениях не нуждаемся, благодарствуйте!

Произнес Бильбо Бэггинс наконец. 38

olgalubnina201 olgalubnina201    3   27.11.2021 13:21    17

Ответы
zepp1 zepp1  03.01.2022 04:28

Python:

strings = []

string = input()

kind_lines = []

while 'Бэггинс' not in string:

   if 'добр' in string.lower(): kind_lines.append([string, len(string)])

   string = input()

if len(kind_lines) == 0:

   print(0)

else:

   kind_lines.sort(key=lambda x: x[1])

   print(kind_lines[0][1])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика