Как это ( в паскале.) в магазине трилайн периодически бывают скидки. составить программу, которая запрашивает цену покупаемого товара и его количество, информацию о скидке (в процентах, если скидки нет, то ввести 0%). на печать должна выводиться сумма к оплате.

Kek1928 Kek1928    2   22.05.2019 06:40    3

Ответы
daffidovа daffidovа  17.06.2020 09:28

Поверено на Паскале АВС

 

Program PSM;
uses crt;
var
  cena, summa:real;
  kwo,skid : integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln;  writeln;
  writeln('++');
  writeln('|             Приветствуем вас в магазине ТРИЛАЙН!              |');
  writeln('++');
  writeln('|       Введите необходимую информацию ниже:       |');
  writeln('++');
  write('       Цена товара:  '); readln(cena);
  write('       Количество единиц товара:  '); readln(kwo);
  write('       Размер скидки в % (0 - если скидки нет) '); readln(skid);
  writeln('++');
  writeln('|                                                               |');
  writeln('|                 Сумма к оплате: ',cena*kwo*(1-skid/100):10:2,'                    |');
  writeln('|                                                               |');
  writeln('++');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика