Известно что а кг груш стоит x руб. Составьте программу вычисляющую цену z кг груш. Значения переменных a, x, z ввести с клавиатуры (паскаль 7 класс) даны а, b, c. Напишите программу для вычисления значения арифметичесеого выражения
x=3c²- b³ :c²+4( паскаль, 7 класс) ​

femalewolf1309 femalewolf1309    1   01.02.2021 22:07    3

Ответы
ник10910 ник10910  03.03.2021 22:15

Задание 1:

program prog;

var x,a,z:real;

begin

  write('Введите а кг груш и х стоимость этого количества (через пробел): '); readln(a, x);

  write('Введите z кг груш, стоимость которой надо посчитать: '); readln(z);

  write('Стоимость ', z:0:1, ' кг груш равна ', z*x/a:0:2);

end.

Задание 2:

У вас скорее всего ошибка в задании, т.к. на входе есть переменная a, а в формуле она отсутствует. Я предположил, что она на первом месте стоит.

program prog;

var a,b,c:real;

begin

  write('Введите a, b и c черезпробел: '); readln(a,b,c);

  write('3a²-b³:c²+4 = ', 3*sqr(a)-exp(3*ln(b))/sqr(c)+4:0:2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика