tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Из массива х(n), n =20,
Из массива х(n), n< =20, по невозрастанию значений эле- ментов, переписать в массив y без повторов значения элементов с четными индексами, меньшие c, сохранив программа на с++
alekss84
3 03.09.2019 02:50
5
Ответы
Денис29964
06.10.2020 13:45
Int main()
{
int
*array_X,
*array_Y,
numOfEl,
border_C,
prevNum;
cout << "Input N: ";
cin >> numOfEl;
array_X = new int[numOfEl];
array_Y = new int[numOfEl / 2];
cout << "Input C: ";
cin >> border_C;
for (int i = 0; i < numOfEl; i++)
cin >> array_X[i];
prevNum = border_C;
for (int i = 0, j = 0; i < numOfEl; i += 2)
if (array_X[i] < border_C && array_X[i] != prevNum)
array_Y[j++] = prevNum = array_X[i];
cout << endl;
for (int i = 0; i < numOfEl; i++)
cout << array_X[i] << "; ";
cout << endl;
for (int i = 0; i < numOfEl / 2; i++)
cout << array_Y[i] << "; ";
system("pause");
return 0;
} /* End of the 'main' function */
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
полина20042012
02.02.2021 11:35
Спишите последний вариант кода программы из урока. Дополните ее веткой else, обрабатывающие случаи, когда пользователь вводит числа не входящие в заданные четыре диапазона....
zuhranormatova0
02.02.2021 11:35
Набор несортированных элементов, которые можно открыть с ключа. dictionarytuplebooltan...
guseva2yul
25.09.2019 04:40
Пусть в массиве т (30) записана температура воздуха за ноябрь. составить программу, которая выведет на экран день,когда была самая а) низкая температура. б) высокая температура....
qawsed123
25.09.2019 04:40
Укажите основание системы счисления, в которой запись числа 94 начинается на 23....
Canyon77
13.08.2019 11:40
Каковы основные свойства алгоритмов ( примеры)?...
aydinlileman7
13.08.2019 11:40
Bчем состоит различие между простыми и составными фильтрами...
Lololoshka98
19.04.2020 12:59
Как вы представляете использование 3D -редактора в своей жизни?...
yaroslavvorobep016v5
19.04.2020 12:59
ответить на во они в изображении)...
husravh323
28.06.2019 12:50
20мин+50с= 10мин+30с= 4ч+30мин= 20мин+50с= 2ч+25мин= 10мин-30с= !...
alholod2p00me0
28.06.2019 12:50
Площадь комнаты 15,4 метров в квадрате, что составляет 22% площади всей квартиры. найдите площадь квартиры....
Популярные вопросы
Крестьянские восстания во франции и 1) начало восстания 2) причина 3) ход...
1
Прямая, параллельная основанию ac равнобедренного треугольника abc, пересекает...
3
Рассчитайте массовую долю (%) элементов в оксиде фосфора (v)...
1
Решите систему 3x^2+2y^2=11 х+2у=3 ))...
3
Шар, свободно движущийся со скоростью 6 м/с, ударился о другой шар и, двигаясь...
1
Сочинение на кыргызском языке.менин кыялым...
1
Написать улюблений твiр укр мова 6 класс...
3
А)форма листовой пластинки у пасленовых...
2
Тема и идея стихотворения есть в осени первоначальной...
2
Барсов или барсов «в семействе барсов и волков»...
2
{
int
*array_X,
*array_Y,
numOfEl,
border_C,
prevNum;
cout << "Input N: ";
cin >> numOfEl;
array_X = new int[numOfEl];
array_Y = new int[numOfEl / 2];
cout << "Input C: ";
cin >> border_C;
for (int i = 0; i < numOfEl; i++)
cin >> array_X[i];
prevNum = border_C;
for (int i = 0, j = 0; i < numOfEl; i += 2)
if (array_X[i] < border_C && array_X[i] != prevNum)
array_Y[j++] = prevNum = array_X[i];
cout << endl;
for (int i = 0; i < numOfEl; i++)
cout << array_X[i] << "; ";
cout << endl;
for (int i = 0; i < numOfEl / 2; i++)
cout << array_Y[i] << "; ";
system("pause");
return 0;
} /* End of the 'main' function */