/ивт 9 класс делфи / паскаль/ 50 напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. время работы программы должно быть пропорционально корню из n. входные данные программа получает на вход одно число n< 2^31. выходные данные программа должна вывести все простые натуральные делители числа n с учетом кратности в порядке неубывания. примеры входные данные 6 выходные данные 2 3

obilan228 obilan228    3   06.08.2019 10:10    6

Ответы
12389p 12389p  04.10.2020 00:52
Var
 n,d,k:int64;
begin
 read(n);
 d := 2; k := 4;
 while k <= n do
  begin
  while n mod d = 0 do
    begin
    write(d,' ');
    n := n div d;
    end;
  k := k + 2*d + 1;
  d := d + 1;
  end;
 if n > 1 then write(n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика