Исправить ошибки и написать блок-схему. : имеется массив а из n произвольных чисел, среди которых есть положительные, отрицательные и равные нулю. используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных. листинг программы: program massiv; const n=10; var a: array [1..4] of integer; i, c, c2, c3: integer; begin for i=1 to n do begin readln (a[i]); if (a[i]=0 then inc(c) else if ([ai]< 0) then inc(c2) else inc (c3); end; writeln (`нулевые: `,c); writeln (`отрицательные: `,c2); writeln (`положительные: `,c3); end.

fyz070504 fyz070504    3   21.05.2019 23:10    1

Ответы
785600 785600  16.06.2020 22:48

uses crt;

var i,d,o,n,m:integer;
a:array[1..100] of integer;
begin
readln(n);
randomize;
for i:=1 to n do a[i]:=random(101)-50;
for i:=1 to n do begin
if a[i] < 0 then o:=o+a[i]
else inc(d);
if a[i] = 0 then inc(m);
end;
for i:=1 to n do write(a[i],' ');
writeln;
writeln('null = ',m);
writeln('otr = ',o);
writeln('pol = ',d);
readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика