Используя признаки делимости, написать программу в паскале, которая проверяет, делится ли натуральное число k на 4 (две последние цифры нули или образуют число, делящееся на 4).

ЯнаLove7 ЯнаLove7    3   24.09.2019 10:20    7

Ответы
Regina391 Regina391  10.09.2020 15:58
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('n=');
  var a:=k mod 10; // поледняя цифра
  var b:=(k mod 100) div 10; // предпоследняя цифра
  if (a=0) and (b=0) or ((10*b+a) mod 4=0) then Writeln('Делится на 4')
  else Writeln('Не делится на 4')
end.

Пример
n= 567264
Делится на 4
ПОКАЗАТЬ ОТВЕТЫ
ok683000 ok683000  10.09.2020 15:58
Program qwerty;
var k, a:integer;
begin
readln(k);
a:=k mod 100;
if(a=0) or (a mod 4=0) then write('Да')
else write('Нет')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика