tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Используя одномерный массив
Используя одномерный массив поменять местами первый минимальный и последний максимальный элементы с++
Nika34562
2 14.09.2019 23:50
2
Ответы
Стивен12
07.10.2020 15:34
#include <iostream>
using namespace std;
int main() {
const int n = 10;
int a[n];
int min, max, imin, imax;
srand(time(0));
for (int i = 0; i < n; i++) {
a[i]=rand() % 5 +1;
cout << a[i] << " ";
}
cout <<"\n";
min = a[0]; imin = 0;
max = a[0]; imax = 0;
for (int i = 1; i < n; i++){
if (a[i]<min) {min = a[i]; imin = i;}
if (a[i]>=max) {max = a[i]; imax = i;}
}
a[imin] = max;
a[imax] = min;
for (int i = 0; i < n; i++) {
cout << a[i] << " ";
}
cout <<"\n";
return 0;
}
Пример:
4 5 4 2 4 3 5 4 4 2
4 5 4 5 4 3 2 4 4 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Kaonix
21.04.2020 14:49
Задача: Дана длина окружности. Определить площадь круга.Ученик не дописал решение задачи. Заполните пропуски так, чтобы программа решала поставленную задачу. Для необходимых вычислений...
NyushaLove
21.04.2020 14:49
6.На вход программе подается натуральное число. Найдите самую большую цифру числа.Питон плищ...
denik228
21.04.2020 14:49
как вывести текстуру на node js...
Anacmasnz106
24.08.2019 00:20
Наберите 7 литров воды. объемы сосудов-6,10,15 литров. с 7 действий. в итоге должно остаться во втором сосуде 7, а в двух других по 0 заранее ....
megasashabori
01.07.2019 18:20
Дан числовой ряд и некоторое число eps. найти сумму тех членов ряда, модуль кото-рых больше или равен заданному eps. общий член ряда имеет вид: 6. an=n! /(2n)!...
nastyayudina21
17.12.2020 14:31
таблица кодировки букв и правила перевода чисел из 2 в 10 расшифруйте приведенное слово 1101 0100 1010 1011.БУКВА А-1,В-2Д-3,Е-4,Ж-5,И-6,К-7,Л-8,М-9,Н-10,О-11,П-12,Р-13,Ь-14,Ш-15...
keram1it228
17.12.2020 14:31
Задание № 1. Перевести числа из одной системы счисления в другую. 1. 41 10=Х2 2. 398 10=Х2 3. 41 10=Х8 4. 398 10=Х8 5. 48 10=Х16 6. 415 10 = X16 7. 11000011 2=Х10 8. 101010 2=Х10...
krasnov595egr
17.12.2020 14:33
Застосування моніторингових систем...
361212
11.05.2020 16:00
До ть будь ласкаМатематика 6 клас...
katyafedorenko1
11.05.2020 16:00
Напишите краткую биографию философа Джона Дьюи.(с интернета копировать не нужно)...
Популярные вопросы
Примеры проводников и изоляторов. главное что бы эти вещи можно было найти в условиях...
2
Подбери числа и реши уравнения х: 9= х+75=? •? х•8=? +? х-80=? : ? 56: х=? : ?...
1
Сразвернутым ответом подумать какие программы вы установили бы на свой компьютер...
2
Окружающий мир 1класс. продолжительность жизни деревьев...
3
Сколько орехов белочка положит в четвертый ряд...
2
Какую часть периметра равностороннего треугольника составляет длина одной стороны...
2
Краса людини - зовнішння і внутрішння...
3
Принадлежность к культурно- эпохе, художественный стиль и направление архитектурного...
2
Из поселка выехал велосипедист скоростью 15км в час. через 3часа вслед ним выехал...
3
1. какие проблемы в нашей стране вскрыла северная война? почему в первые годы петр...
2
using namespace std;
int main() {
const int n = 10;
int a[n];
int min, max, imin, imax;
srand(time(0));
for (int i = 0; i < n; i++) {
a[i]=rand() % 5 +1;
cout << a[i] << " ";
}
cout <<"\n";
min = a[0]; imin = 0;
max = a[0]; imax = 0;
for (int i = 1; i < n; i++){
if (a[i]<min) {min = a[i]; imin = i;}
if (a[i]>=max) {max = a[i]; imax = i;}
}
a[imin] = max;
a[imax] = min;
for (int i = 0; i < n; i++) {
cout << a[i] << " ";
}
cout <<"\n";
return 0;
}
Пример:
4 5 4 2 4 3 5 4 4 2
4 5 4 5 4 3 2 4 4 2