Используя цикл с параметром, написать программу, которая вычисляет сумму заданного с клавиатуры числа элементов ряда 1/2+1/4-1/6+1/

Nikidiy Nikidiy    1   24.10.2019 09:15    2

Ответы
Alex171810 Alex171810  10.10.2020 09:15

program Calc;

var

 i, n, m: Integer;

 s: Double;

begin

 Write ('Количество членов ряда = ');

 ReadLn (m);

 s := 0.5;

 n := 1;

 for i := 2 to m do begin

   s := s + n / (i * 2);

   n := -n;

 end;

 WriteLn ('S = ', s :20 :20);

 ReadLn;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика