Информатика Составьте программу нахождения произведения всех натуральных чисел из диапазона от А до В, включая А и В, кратных 2 и 3 одновременно(А и В вводятся с клавиатуры).

jokertop666 jokertop666    3   17.05.2020 07:45    4

Ответы
bmonolova1980 bmonolova1980  14.10.2020 21:00

program z1;

var i,a,b,p:integer;

begin

write('a = ');

readln (a);

write('b = ');

readln (b);

p:=1;

for i:=a to b do

if (i mod 2 = 0) and (i mod 3 =0) then p:=p*i;

if p <> 1 then writeln ('Произведение чисел, кратных 2 и 3 одновременно, равно ',p)

end.

Объяснение:

Если таких чисел нет, то программа ничего не выводит.

Если промежуток очень большой, то лучше изменить тип p (например, на real), чтобы не было переполнения.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика