Информатика - : составить программу, в которой с клавиатуры вводятся два текстовых выражения. необходимо: 1) выбрать и вывести на экран более длинное из них 2) проверить и вывести на экран то из них, у которого первая и вторая буквы - одинаковая (регистр букв можно не учитывать) 3) проверить, входит ли короткое слово в состав длинного 4) вставить в короткое слово на чётные позиции буквы "а" дополнительно к тому, что есть 5) подсчитать суммы кодов символов, использованных в длинном слове

bulatik311 bulatik311    3   26.08.2019 19:30    2

Ответы
Human333 Human333  05.10.2020 21:29
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString('Первое слово:');
  var s2:=ReadlnString('Второе слово:');
  // #1
  Writeln('Задание 1) ',s1.Length>s2.Length?s1:s2);
  // #2
  if s1[1]=s1[2] then Writeln('Задание 2) ',s1);
  if s2[1]=s2[2] then Writeln('Задание 2) ',s2);
  // #3
  Write('Задание 3) Более короткое слово ');
  // предполагаем, что s1 более короткое.
  // Если это не так, меняем их местами.
  if s1.Length>s2.Length then Swap(s1,s2);
  if pos(s1,s2)=0 then Write('не');
  Writeln(' входит в более длиное');
  // #4
  s1:=s1.ToCharArray.Select((c,i)->i mod 2<>0?'a'+c:c).JoinIntoString('');
  Writeln('Задание 4) ',s1);
  // #5
  Writeln('Задание 5) Сумма кодов (в UNICODE) для длинного слова: ',
      s2.ToCharArray.Select(c->integer(Ord(c))).Sum)
end.

Примеры
Первое слово: Колокольчик однозвучный утомительно звенит
Второе слово: дно
Задание 1) Колокольчик однозвучный утомительно звенит
Задание 3) Более короткое слово  входит в более длиное
Задание 4) дaно
Задание 5) Сумма кодов (в UNICODE) для длинного слова: 42383

Первое слово: ссора
Второе слово: рессора
Задание 1) рессора
Задание 2) ссора
Задание 3) Более короткое слово  входит в более длиное
Задание 4) сaсоaра
Задание 5) Сумма кодов (в UNICODE) для длинного слова: 7589
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика