Информатика: решение на языке паскаль. текст : даны три натуральных числа. напишите программу, определяющую существует ли треугольник с такими длинами сторон. если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, разносторонний)

12345678Natalya 12345678Natalya    3   23.09.2019 05:40    1

Ответы
РускийЧатик РускийЧатик  04.08.2020 14:39
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('a b c =');
  if (a+b>c) and (a+c>b) and (b+c>a) then
    if (a=b) or (a=c) or (b=c) then
      if (a=b) and (b=c) then Writeln('Треугольник равносторонний')
      else Writeln('Треугольник равнобедренный')
    else Writeln('Треугольник разносторонний')
  else Writeln('Треугольник не существует')
end.
ПОКАЗАТЬ ОТВЕТЫ
09kok90 09kok90  04.08.2020 14:39
Var       
i, a, b, c: integer;

function check_is(a, b, c: integer):
 boolean;
begin     
 if a >= b + c then check_is := false
else        if b >= a + c then
 check_is := false else     
  if c >= a + b then check_is := false else     
         check_is := true;           
       end;
procedure check_how(a, b, c: integer);begin 
     if ((a = b) and (b = c) and (a = c)) then writeln('равносторонний') else   
    if ((a = b) or (b = c) or (a = c)) then writeln('равнобедренный') else              writeln('разносторонний');     
  end;

begin     
 writeln('Введите стороны треугольника');   
    read(a, b, c);   
    if check_is(a, b, c) then check_how(a, b, c) else writeln('Нет такого треугольника!');          
   end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика