Информатика. Питон. Программа #1 :
1) Введите свое имя:

б) выведите на экран 1-й и 3-й символы;

в) определите, совпадают ли 1-й и последний символы вашего имени.

Программа #2 :
2) Напишите программу, которая запрашивает ввод нескольких слов с клавиатуры, а затем определяет длину самого короткого слова в строке.

Егорка2910 Егорка2910    3   27.02.2021 07:33    11

Ответы
SHAHRUKH575 SHAHRUKH575  29.03.2021 07:35
1)

name = input("Имя: ").lower()

print("1-й и 3-й символы:", name[0],"и",name[2])

if name[0] == name[len(name)-1]:

    print("Совпадают ли 1-й и последний символы вашего имени:", "Да")

else:

    print("Совпадают ли 1-й и последний символы вашего имени:", "Нет")

 2)

s = [i for i in input().split()]

min = len(s[0])

for i in s:

    if len(i) < min:

        min = len(i)

print("Длина самого короткого слова: ",min)


Информатика. Питон. Программа #1 : 1) Введите свое имя:б) выведите на экран 1-й и 3-й символы;в) опр
Информатика. Питон. Программа #1 : 1) Введите свое имя:б) выведите на экран 1-й и 3-й символы;в) опр
ПОКАЗАТЬ ОТВЕТЫ
Kristina17217 Kristina17217  29.03.2021 07:35

# 1

name = input("name: ") .lower()

# б

print(name[0], name[2])

# в

if name[0] == name[-1]:

   print("Совпадает")

else:

   print("не совпадает")

# 2

mins = None

for i in range(5):

   a = input("Слово: ")

   if mins == None: mins = len(a)

   elif len(a) < mins: mins = len(a)

print(f"Длина самого короткого слово составляет {mins} символов")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика