Информатика , паскаль Задача:
Чтобы быть всегда чистым, человеку нужно х (24≤х≤50) кусков мыла в год. Если мыть только пяти, то мыла понадобится в 12 раз меньше, а только уши - еще на 1 кусок меньше. Составить программу, которая по выбору пользователя давала ответ количество кусков мыла необходимо закупить на n лет вперед, чтобы: мыться полностью; мыть только пятки;мить только уши;мыть пятки и уши

анюта1335 анюта1335    3   04.12.2020 19:18    4

Ответы
Darklife1 Darklife1  03.01.2021 19:21

var x1:real:=24;

   x2:real:=50;

    N:real;

begin

write('Введите число лет: '); readln(N);

var A:=((x1/12).Round*N,(x2/12).Round*N);

var B:=(((x1/12).Round-1)*N,((x2/12).Round-1)*N);

writeln('Для мытья полностью нужно ',x1*N,'-',x2*N,' кусков мыла');

writeln('Для мытья одних пяток нужно ',A[0],'-',A[1],' кусков мыла');

writeln('Для мытья одних ушей нужно ',B[0],'-',B[1],' кусков мыла');

writeln('Для мытья пяток и ушей нужно ',A[0]+B[0],'-',A[1]+B[1],' кусков мыла');

end.

Объяснение:

В программе использован метод кортежей (Tuple): A и В - переменные с двумя ячейками под запись. Значения внутри них нельзя изменить, однако можно считать, подобно обращению к массиву. При том следует помнить, что нумерация индексов (адресов ячеек) начинается с нуля. Используя B[0] мы обращаемся к первому его значению, то есть к выражению ((x1/12).Round-1)*N.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика