Информатика.паскаль.дано натуральное число n. составить программу, которая определяет, сколько цифр этого числа кратны трем. p.s т.е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.

Fatima0952006 Fatima0952006    1   18.05.2019 07:30    4

Ответы
SmolentsevaMasha SmolentsevaMasha  11.06.2020 13:57

var

  N, count:integer;

begin

   write('N = ');

  readln(N);

  count := 0;

  while N > 0 do

  begin

    if (N mod 10) mod 3 = 0 then

      count := count + 1;

    N := N div 10;

  end;

  writeln('Count = ', count);

  readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика