Информатика (Паскаль)

№ 1. Запишите значение переменной s, полученное в результате работы следующей программы.

var s,k: integer;

begin

s := 0;

for k := 4 to 7 do

s := s + 8;

writeln(s);

end.

№ 2. Запишите значение переменной s, полученное в результате работы следующей программы.

var s,k: integer;

begin

s := 0;

for k := 3 to 8 do

s := s + 9;

writeln(s);

end.

№ 3. Вычислить количество натуральных чисел от 1 до N.

№ 4. Написать программу вычисления произведения натуральных чисел от 12 до 14.

​

Юліан11 Юліан11    2   29.03.2021 15:10    4

Ответы
gek45 gek45  29.03.2021 15:20

Задача №1

Смотрим на цикл, при выполнении программы он пройдёт 4 итерации.

Тогда S = 8 * 4 = 32

ответ: 32

Задача №2

Смотрим на цикл, при выполнении программы он пройдёт 5 итераций.

Тогда сначала s = 1 * 2 = 2, потом s = 2 * 2 = 4, затем s = 4 * 2 = 8,  затем s = 8 * 2 = 16, затем s = 16 * 2 = 32,

ответ: 32

Задача №3

Здесь будет 11 итераций цикла, 100 - 5 * 11 = 45 (т.к. s = 100, за один проход - 5 от значения s)

ответ: 45

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика