)информатика pascalabc.net 1)составьте программу , которая выводит на экран все двухзначные числа,сумма цифр которых делится на 7. 2)составьте программу: с клавиатуры вводятся два натуральных числа x и y. вывести на экран все четные числа на отрезке [x,y] и подсчитать сумму этих чисел.

ivanm29 ivanm29    1   09.09.2019 13:40    2

Ответы
хели3 хели3  26.08.2020 18:10
PascalABC.NET 3.3, сборка 1555 от 21.10.2017
Внимание! Если программа не работает, обновите версию!

№1

begin
  for var i:=10 to 99 do
    if (i div 10 + i mod 10) mod 7=0 then Print(i);
  Writeln
end.

Результат
16 25 34 43 52 59 61 68 70 77 86 95

№2

begin
  var (x,y):=ReadInteger2;
  Writeln('S=',x.To(y).Where(i->i.IsEven).Println.Sum)
end.

Пример
5 30
6 8 10 12 14 16 18 20 22 24 26 28 30
S=234
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика