Информатика ! : напишите программу на паскаль с которой можно вычислить сумму и количество всех двузначных четных чисел.(цикл while). заранее я вроде разбираюсь в инфе, но что-то эту никак не ​

ВероникаФардзинова ВероникаФардзинова    2   16.04.2019 18:02    2

Ответы
tepop13 tepop13  29.05.2020 16:17

program raf105;

var a,sum,col:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы узнать результат введите 0');

a:=1;

while a<>0 do

begin

 readln(a);

 if (10<=a) and (a<=99)

   then if a mod 2 = 0

     then

     begin

     sum:= sum+a;

     col:= col+1

     end;

end;

writeln('Количество чётных двузначных чисел: ',col);

writeln('Их сумма: ',sum);

end.

Написано на языке PascalABC.NET

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика