tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Информатика , 9 класс.
Информатика , 9 класс. паскаль . решит. 2. в первый день ученик выучил 3 ̆ских слова, а в каждый следующий день – на 1 слово больше, чем в предыдущий. составить программу для вычисления количества слов, выученных учеником за неделю.
Maryna03
2 14.09.2019 16:50
3
Ответы
Gergoo
07.10.2020 14:44
Var k,s,i:integer;
begin
k:=3;
s:=3;
for i:=2 to 7 do
begin
k:=k+1;
s:=s+k;
end;
writeln('Количество выученных слов = ',s);
end.
Результат:
Количество выученных слов = 42
ПОКАЗАТЬ ОТВЕТЫ
zarraban
07.10.2020 14:44
Пусть в первый день ученик выучил k слов.
Тогда за n дней он выучит
Теперь можно написать программу. Известно, что k=3, n=7.
Ручной счет дает 3×7+6×7/2 = 21+21 = 42.
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (k,n):=(3,7);
Writeln(k*n+n*(n-1) div 2)
end.
Результат
42
Хорошая иллюстрация случая, когда для решения задачи компьютер не нужен. Так бывает, когда составители заданий думают тем, на чем сидят.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
adventuretime93
07.09.2019 00:50
улучшения зрения доклат по физре !...
pe4enka7834727257382
07.09.2019 00:50
Запиши развёрнутую запись числа 0,164 для дробной части числа....
anet1983
03.10.2019 13:50
Номер 99 скорость передачи данных по некоторому каналу равна 64 000 бит/с. передача файла по этому каналу связи заняла 4 мин. определите размер файла в мегабайтах...
nazarenkolavrenyuk
03.10.2019 13:50
Какие предложения являются высказываниями ? 1) рукописи не горят 2)обязательно стать отличником 3)никакая причина не извиняет невежливость 4)1011= 1*2+0*2+1*2+1*2...
udovilyudmila
08.04.2020 13:56
Запишите 32-битный IP-адрес в виде четырёх десятичных чисел, разделённых точками: 11110100101101001101001001001101...
svetika0813
28.05.2019 23:30
Сделать загадку с признаком на что похоже например есть кольчуга а не воин есть веер а не веер принцессы ответ рыба...
dasha505dasha
19.10.2020 07:23
поместите куб в декартовой системе координат так чтобы одна из вершин кординаты (0;0;0) и еще одна была с координатоми (3;0;0) укажите координаты остальных вершин...
kaskader2475
19.10.2020 07:23
Соціальне, політичне та культурне життя ацтеків, мая та інків(1-2 предложение на каждый ответ)...
250alina250
19.10.2020 07:23
длина комнаты 18 метров.Ее ширина составляет 1/3 длины,а высота 1/3 ширины.найти высоту и ширину комнаты.нужны условия к задаче...
rasputniya
19.10.2020 07:23
Как называются графики тригонометрических функции??...
Популярные вопросы
Разность чисел 0,76 и 0,4 скольки равна: ...
3
Выполните сложение и вычитание дробей:а) 2a - 1/5b + a/b b) 3/x2 - 1 - 2/x...
1
Ідея патріотичного оптимізму та життєлюбства у творах Олега Ольжича й Олени...
3
2. Выпишите 10 ключевых слов и словосочетаний во второй части....
1
Отырыс, кінәлі, даулы, ізгі, болашақ, шешумамандық, жауапты, бейкүнә, үстемдік,...
2
5 x - 3 1/2 равно 4 2/3 Найдите корни уравнения...
2
Співзвучним головній думці новели Акутагава «Павутинка» є прислів’я:...
2
у лукаморья дуб зеленый о каких чудесах говорит поэт во второй части, . составь...
1
Эссе на тему «Что я могу показать туристам в своём родном городе Сумы?»...
3
Найдите объём прямоугольного параллелепипеда, если его измерения равны 7 см,...
3
begin
k:=3;
s:=3;
for i:=2 to 7 do
begin
k:=k+1;
s:=s+k;
end;
writeln('Количество выученных слов = ',s);
end.
Результат:
Количество выученных слов = 42
Тогда за n дней он выучит
Теперь можно написать программу. Известно, что k=3, n=7.
Ручной счет дает 3×7+6×7/2 = 21+21 = 42.
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (k,n):=(3,7);
Writeln(k*n+n*(n-1) div 2)
end.
Результат
42
Хорошая иллюстрация случая, когда для решения задачи компьютер не нужен. Так бывает, когда составители заданий думают тем, на чем сидят.