Ине нужно писать просто так, только программу. массив из 8 элементов содержит оценки за четверть. заполнение его организовать с клавиатуры. написать программу, которая вычислит четвертную оценку и выведет ее на экран. для этого будет необходимо: 1. найти сумму элементов массива. 2. посчитать среднее арифметическое оценок – x. 3. округлить х до отметки. правило, как выставляются оценки за четверть: 0

arinakurbatovu arinakurbatovu    2   12.09.2019 20:00    4

Ответы
Сумасшедшая55555 Сумасшедшая55555  07.10.2020 10:20
Var
s, i: integer;
x:real;
mas: array [1..8] of integer;
begin
s:=0;
for i:=1 to 8 do
begin
readln (mas[i]);
s:=s+mas[i];
end;
x:=s/8;
If (x>0) and (x<2.49) then write ('2');
If (x>=2.5) and (x<=3.49) then write ('3');
If (x>=3.5) and (x<=4.49) then write ('4');
If (x>=4.5) and (x<=5) then write ('5');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика