Ii тограммирование»
вариант
1. в программе описан одномерный целочисленный массив асиплексами от 0 до 10
ниже представлен фрагмент этой программы, записанный на языке pascal, в
котором значения элементов массива сначала заднотся, а затем меняются
for i: =0 to 10 do
a[0]: =i+3;
for i: =10 downto 1 do
a[i-1]: = a[i]);
чему будут равны элементы утого массива после выполнения
программы?
того фрагмента
2 значения двумерного массива дразмера 8х8 залаioтся с воженного
оператора цикла в представленном фрагменте программы
for i: =1 to 8 do
for j: =1 to 8 do
a[i]: =ii-i;
сколько элементов массива а будут равны нулю?
3. в программе описан одномерный целочисленный массив ас индексами от 0 до 10
hске представлен фрагмент этой программы, записанный на языке pascal, в
котором значения элементов массива сначала , а затем меняются
for i: =0 to 10 do
a[i]: =i+2;
for i: = 0 to 10 do
begin
а(10-i]: = a[i]:
a[i] = а(10-і);
end;
чему будут равны элементы этого массива после выполнения того фрагмента
программы?
4. var x,y: string, l: byte;
begin
х='информация,
y='автоматика".
delete(x,6,5);
delete(y,1,4);
1: =length(x+y):
write (z);
чему будет равна переменная 7 после выполнения того фрагмента программы?
5. составьте программу подсчета суммы всех отрицательных элементов заданного це-
лочисленного массива размером 30 элементов если отрицательных элементов нет
сообщите об этом (элементы массива произвольные целочисленные числа, которые
вводит пользователь).
7. дана исходная строка (вводиться с клавиатуры) составьте программу, которая
подсчитывает количество букв «b» в этой строке.​

мари420 мари420    2   18.12.2019 08:18    1

Другие вопросы по теме Информатика