Идет i-ая секунда суток. напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с с начала суток. например: 13257 секунд = 3 часа 40 минут и 57 секунд. выведите на экран фразу: «с начала суток часов, ….. минут и …. секунд». вместо многоточий вывести значения переменных.

olenkakireeva1 olenkakireeva1    2   22.06.2019 17:10    6

Ответы
fasgame fasgame  02.10.2020 08:36
Var
  i, h, m, s: integer;

begin
  Write('Введите количество секунд от начала суток: ');
  Readln(i);
  h := i div 3600;
  m := i mod 3600;
  s := m mod 60;
  m := m div 60;
  Writeln('С начала суток часов, ', m, ' минут ', s, ' cекунд')
end.

Тестовое решение:
Введите количество секунд от начала суток: 13257
С начала суток часов, 40 минут 57 cекунд
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика