Хотя бы 3-4 ! 1) дан одномерный целочисленный массив размерностью n. найдите количество элементов, которые кратны 3 (5). 2) дан одномерный целочисленный массив а, состоящий из n элементов. найти сумму всех четных элементов массива. 3) дан одномерный целочисленный массив а, состоящий из n элементов. найдите произведение всех нечетных элементов массива. 4) дан двумерный массив размерностью nxm, заполненный случайными числами. заменить все четные элементы массива на 2, а нечетные на 1. на экран вывести исходный и новый массив. 5) дан двумерный массив размерностью nxm, заполненный случайными числами. напишите программу, в результате выполнения которой все элементы массива увеличиваются в 2 раза. на экран вывести исходный и новый массив.

ОленкаБурковська ОленкаБурковська    1   18.06.2019 11:20    3

Ответы
eduardpiterskiy eduardpiterskiy  15.07.2020 06:25
Сделал все!) поставь наилучшее!

1)var a:array [0..5] of Integer;    i,j:Integer;
begin 
Randomize;
 j:=0;
for i:=0 to 5 do
 a[i]:=Random(100);
for i:=0 to 5 do
 if a[i] mod 3 =0 then 
Inc(j);
Writeln(j);
readln;
2)var a:array [0..5] of Integer;    i,j:Integer;
begin
 Randomize; 
j:=0;
for i:=0 to 5 do 
a[i]:=Random(100);
for i:=0 to 5 do
 if a[i] mod 2 =0 then 
 j:=j+a[i];
Writeln(j);
readln;
3)a:array [0..5] of Integer;    i,s:Integer;
begin
Randomize;
s:=1;
for i:=0 to 5 do 
a[i]:=Random(9)+1;
for i:=0 to 5 do 
if i mod 2 <>0 then 
 s:=s*a[i];
Writeln(s);
readln;
end.
4)const n=5;m=5;
var a:array [0..n,0..m] of Integer;    i,j:Integer;
begin 
Randomize;
for i:=0 to n do
for j:=0 to m do
 a[i,j]:=Random(100);
 for i:=0 to n do 
begin 
 Writeln; 
 for j:=0 to m do 
 write(a[i,j]:3);
 end;
for i:=0 to n do
for j:=0 to m do 
begin
 if a[i,j] mod 2 =0 then 
a[i,j]:=2
 else if a[i,j] mod 2 <>0 then 
 a[i,j]:=1;
end;
Writeln;
 for i:=0 to n do
 begin 
 Writeln;
  for j:=0 to m do 
 write(a[i,j]:3);
  end;
Readln;
end.
5)const n=5;m=5;
var a:array [0..n,0..m] of Integer;    i,j:Integer;
begin 
 Randomize;
for i:=0 to n do
for j:=0 to m do
 a[i,j]:=Random(10);
 for i:=0 to n do
 begin 
 Writeln;
  for j:=0 to m do 
write(a[i,j]:3); 
end;
for i:=0 to n do
for j:=0 to m do
a[i,j]:=a[i,j]*2;
Writeln; 
for i:=0 to n do 
begin 
 Writeln; 
 for j:=0 to m do 
 write(a[i,j]:3); 
 end;
Readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика