tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Функция.напишите программу
Функция.напишите программу для нахождения наибольшего числа из 5 чисел. для сравнения двух чисел создать соответствующую функцию
gadukina
3 17.09.2019 05:40
11
Ответы
жак77777
07.10.2020 21:10
Function Max(a,b:real):real;
begin
if a>b then Max:=a
else Max:=b
end;
var
a,b,c,d,e,m:real;
i:integer;
begin
Writeln('Введите 5 чисел: ');
Read(a,b,c,d,e);
m:=Max(a,b);
m:=Max(m,c);
m:=Max(m,d);
m:=Max(m,e);
Writeln('Максимум: ',m)
end.
Пример
Введите 5 чисел:
2.3 4 -5.16 0 0.087
Максимум: 4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
wutter99
16.10.2020 08:06
Какие доработки цифрового материала из интернета вы знаете? На какие из них нужно брать разрешение у авторов? ...
феня163
16.10.2020 08:06
Определите результаты работы алгоритма:...
rimolol
23.12.2020 10:13
Сколько значащих нулей в двоичном представлении числа 13? с решением...
asikg27
19.11.2020 19:07
С ЭТИМ ЗАДАНИЕМ ДОБРЫЕ ЛЮДИ >...
женя1378
19.11.2020 19:07
Моно, 10с, 940 Кбайт, (8 бит – плохое, 16 бит – хорошее качество). Какое качество звука?...
saddsa17
16.10.2020 06:42
Сжать текст по алгоритму Хаффмана, построив дерево. Рассчитать коэффициент сжатия. Ловко лавируя в ларингологии, лекарь-ларинголог легко излечивал ларингиты. Маланья-болтунья...
artem2006sokol
16.10.2020 06:44
Заданы два числа. Если их сумма больше восьми, увеличить эти два числа в 5 раз. Иначе уменьшить первое на 7, второе на 5( Паскаль)...
AlinaZimina2003
08.06.2019 12:00
Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 39 оканчивается на 3...
Bublick08
08.06.2019 12:00
4. составить программу проверяющую, лежит ли точка с указанными координатами x, y на окружности радиуса r с центром в начале координат...
Mariaxmxm
08.06.2019 12:00
:) последовательно вводятся n целых чисел. найти среднее арифметическое этих чисел....
Популярные вопросы
В каких условиях оказался пушкин после возвращения из ссылки?...
1
менша сторона прямокутника утворює з діагоналлю кут 60 градусів знайди цю...
2
«Менің болашақ жайлы толғанысым» тақырыбында ойтолғау...
3
3.Музыкальный колорит какого направления лег в основу оперы «Порги и Бесс»?...
2
1. Когда тело нагревают до температуры плавления, то размах колебаний молекул...
1
бедному одиннадцатикласснику...
2
read the following statements and make one more statement according to the...
3
Фрагмент начала гена имеет следующую последовательность нуклеотидов (верхняя...
3
Розгорнуту відповідь на питання: чому ліричний герой байрона мріяв жити у...
3
чоловік який жив у минулому столітті сміг відмітити свій день народження,...
3
begin
if a>b then Max:=a
else Max:=b
end;
var
a,b,c,d,e,m:real;
i:integer;
begin
Writeln('Введите 5 чисел: ');
Read(a,b,c,d,e);
m:=Max(a,b);
m:=Max(m,c);
m:=Max(m,d);
m:=Max(m,e);
Writeln('Максимум: ',m)
end.
Пример
Введите 5 чисел:
2.3 4 -5.16 0 0.087
Максимум: 4