Free pascal 1. составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. даны два целых числа x и y. составить программу для нахождения большего из них. 3. составить программу для вывода на экран натуральных чисел от 1 до 10. 4. составить программу для решения : сколько пирожков испечёт хозяйка за неделю, если в первый день она испекла 4 пирожка, а в каждый последующий день – в два раза больше, чем в предыдущий? 5. (*) с клавиатуры вводятся последовательно n натуральных чисел. найти большее из них.

cat73309owz9do cat73309owz9do    1   03.06.2019 13:50    1

Ответы
ТвойЩенок ТвойЩенок  03.07.2020 21:24
1) var a, b, s: real;
begin
read(a, b);
s:=a*b;
writeln(s);
end.

2) var x, y, max: integer;
begin
read(x, y);
if x>y then max:=x else max:=y;
writeln(max);
end.

3) var i:integer;
begin
for i:=1 to 10 do
writeln(i);
end.

4) var i, n:integer;
begin
n:=4;
for i:=1 to 7 do begin
n:=2*n;
writeln(n);
end.

5) var a, n, max:integer;
begin
max:=-MaxInt;
read(n);
for i:=1 to n do begin
read(a);
if a>max then max:=a;
end;
writeln(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика