ФОТО ЭТО ДЛЯ ПОСЛЕДНЕГО ЗАДАНИЯ.

6.

Ниже приведена программа, записанная на пяти языках программирования.

Бейсик Python

DIM s, t AS INTEGER

INPUT s

INPUT t

IF s > 9 OR t > 9 THEN

PRINT ‘YES’

ELSE

PRINT ‘NO’

ENDIF

s = int(input())

t = int(input())

if s > 9 or t > 9:

print("YES")

else:

print("NO")

Паскаль Алгоритмический язык

var s, t: integer;

begin

readln(s);

readln(t);

if (s > 9) or (t > 9)

then writeln('YES')

else writeln('NO')

end.

алг

нач

цел s, t

ввод s

ввод t

если s > 9 или t > 9

то вывод "YES"

иначе вывод "NO"

все

кон

С++

#include <iostream>

using namespace std;

int main() {

int s, t;

cin >> s;

cin >> t;

if (s > 9 || t > 9)

cout << "YES";

else

cout << "NO";

return 0;

}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились

следующие пары чисел:

(9, 9); (9, 10); (8, 5); (11, 6); (–11, 10); (–5, 9); (–10, 10); (4, 5); (8, 6).

Сколько было запусков, при которых программа напечатала «NO»?

7.

Доступ к файлу rus.doc, находящемуся на сервере obr.org, осуществляется по протоколу https.

Фрагменты адреса файла закодированы буквами от А до Ж. Запишите в таблицу последовательность

этих букв, кодирующую адрес указанного файла в сети Интернет.

А) obr.

Б) /

В) org

Г) ://

Д) doc

Е) rus. Ж) https

8.

В языке за поискового сервера для обозначения логической операции «ИЛИ» используется

символ «|», а для логической операции «И» — символ «&».

В таблице приведены за и количество найденных по ним страниц некоторого сегмента сети

Интернет.

За Найдено страниц

(в тысячах)

Сириус & Вега 260

Вега & (Сириус | Арктур) 467

Сириус & Вега & Арктур 119

Какое количество страниц (в тысячах) будет найдено по за Вега & Арктур ? Считается, что все

за выполнялись практически одновременно, так что набор страниц, содержащих все искомые

слова, не изменялся за время выполнения за На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И. По каждой дороге можно

двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из

города А в город И, проходящих через город В?

Эхорит Эхорит    2   14.05.2020 18:50    27

Ответы
People100 People100  14.10.2020 19:04

(9, 9) - No; (9, 10) - Yes; (8, 5) - No; (11, 6) - Yes; (-11, 10) - Yes; (-5, 9) - No; (-10, 10) - Yes; (4, 5) - No; (8, 6) - No

No: 4 запуска

7) https://obr.org/rus.doc - ЖГАВБЕД

8) Сириус & Вега 260; Вега & (Сириус | Арктур) 467;

Сириус & Вега & Арктур 119

Вега & Артур = 326

9) 20 путей

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика