Есть массив (int arr[10] = {5,4,6,17,2,3,16,9,8,1}; ). нужно написать программу, которая меняет все нечетные числа на 1, а четные – на 10. вывести элементы массива в консоль;

irynafurmanets irynafurmanets    3   02.10.2019 11:10    2

Ответы
gaukhars01 gaukhars01  09.10.2020 11:36

#include <iostream>  //подключаем библиотеки

#include <fstream>  //подключаем библиотеки

using namespace std; //пространство имён

int main() {

 

setlocale(LC_ALL, "Russian"); //русский

 

int arr[10] = {5,4,6,17,2,3,16,9,8,1};

 

for(int i = 0; i < 10; i++) //сортируем масссив

{

 if (arr[i] % 2 == 0)  //все четные

 {

  arr[i] = 1;    //меняем значение

  cout << arr[i] << " ";  //выводим

 }else    //все нечетные

 {

  arr[i] = 10;    //меняем значение

  cout << arr[i] << " ";  //выводим

 }

}

 

return 0; //возращаем ничего

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика