Две целочисленный массив из 30 элементов . элементы массива могут принимать целые значения о 0 до 100 - учащихся выпускного класса за итоговый тестер информатике .составьте программу которая позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе ))

shubina021 shubina021    3   26.08.2019 11:20    5

Ответы
Nika2006klubnika Nika2006klubnika  05.10.2020 20:53
Program n1;
const n=30;
var a: array[1..n] of integer;
i,k,sum: integer;
sr: real;
begin
randomize;
sum:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(101);
write(a[i],' ');
sum:=sum+a[i];
end;
sr:=sum/n;
writeln;
for i:=1 to n do if a[i]>sr then k:=k+1;
writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика