Дописать програму

Составить программу, которая бросать случайные числа из интервала от 10 до 50 пока не выпадет

заданное с клавиатуры число А (10<=A<=50). Указать количество «бросков» до совпадения.

Дописать програму

var

x, count, y:integer;

begin

writeln('Задумайие и введите число X (10<=x<=50)');

readln(x);

y:=

count:=

здесь пропущена строка

begin

y:=random(41)+10;

count:=

writeln('Бросок №',count,': y=',y);

end;

writeln;

writeln('Количество бросков до совпадения ', count)

end

julka19981 julka19981    2   13.05.2020 17:24    5

Ответы
Nightmare5467 Nightmare5467  14.10.2020 17:18
ответ:

var

   x, count, y:integer;

begin

   writeln('Задумайие и введите число X (10<=x<=50)');

   readln(x);

   y:=0;

   count:=0;

   while x<>y do

   begin

       y:=random(41)+10;

       count:=count+1;

       writeln('Бросок №',count,': y=',y);

   end;

   writeln;

   writeln('Количество бросков до совпадения ', count)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика