Добрые люди, , , сделать по информатике. 1. напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 3. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: количество всех чётных чисел, кратных 3. 2. напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: количество всех чётных чисел, кратных 7.

Наська0123 Наська0123    2   17.07.2019 04:10    6

Ответы
Vitya619228 Vitya619228  30.08.2020 19:17
Решение 1-й задачи:
//PascalABC.Net
//NaaMan
var
    i, n : integer;
begin
    i := 0;
    repeat
        write('Введите число > ');
        readln(n);
        if (n > 0) then
            if (n mod 2 = 0) then
                if (n mod 3 = 0) then i := i + 1;
    until (n = 0);
    writeln('Количество чётных чисел, кратных 3: ', i)
end.

Для решения второй задачи нужно заменить (n mod 2 = 0) на (n mod 2 = 1) и (n mod 3 = 0) на (n mod 7 = 0).

Добрые люди, , , сделать по информатике. 1. напишите программу, которая в последовательности натурал
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика