Доброго времени суток. , составить программу в паскале. дана последовательность вещественных чисел, содержащих n=15 элементов. построить из неё новую последовательность, так чтобы в её начале располагались все отрицательные, а затем все положительные числа и нули. относительный порядок расположения как отрицательных, так и не отрицательных должен быть сохранён

vitalina05062005 vitalina05062005    3   02.06.2019 00:10    2

Ответы
настя123456789108 настя123456789108  02.07.2020 22:35
Var 
res,mas:array[1..100] of real; 
k,i:integer;
begin 
k:=0; 
for i:=1 to 15 do   
read(mas[i]); 
for i:=1 to 15 do  
begin   
if mas[i]<0 then     
write(mas[i],' ')   
else   
begin     
k:=k+1;     
res[k]:=mas[i];   
end; 
end; 
for i:=1 to k do   
write(res[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика