до вечера

Тест по разделу «Программирование на языке Паскаль»

1 вариант

1. Фиксированная система обозначений для описаний алгоритмов и структур данных называется:

a) языком программирования;

b) языком алгоритмов;

c) программой.

2. Выберите правильную форму записи операции присваивания:

a) 3+У:=Х

b) Х:=3+У

c) Х=3+У

3. Команду алгоритма, записанную на языке программирования, принято называть:

a) действием;

b) шагом;

c) оператором.

4. Оператором ввода данных в языке Паскаль является:

a) WriteLn;

b) ReadLn;

c) Begin … End.

5. Оператором вывода данных в языке Паскаль является:

a) WriteLn;

b) ReadLn;

c) Begin … End.

6. Выберите правильную форму записи структуры программы на языке Паскаль:

a)

Program <имя программы>;

Begin

<операторы>

End;

Var <описание переменных>.

b)

Var <описание переменных>;

Program <имя программы>;

Begin

<операторы>

End. c)

Program <имя программы>;

Var <описание переменных>;

Begin

<операторы>

End.

7. На языке программирования Паскаль выражение а2+b2-12c записывается как:

a) a*a+b*b-12c;

b) sqrt(a)+sqrt(b)-12*c;

c) sqr(a)+sqr(b)-12*c.

Примечание: sqr – это квадрат суммы, sqrt- квадратный корень.

8. Оператором ветвления является:

a) Repeat <операторы> Until <условие>;

b) If <условие> Then <оператор 1> Else <оператор 2>;

c) While <условие> do <операторы>;

d) For i:=<начальное значение параметра> to <конечное значение параметра> do <операторы>.

9. Оператором цикла с предусловием является:

a) Repeat <операторы> Until <условие>;

b) If <условие> Then <оператор 1> Else <оператор 2>;

c) While <условие> do <операторы>;

d) For i:=<начальное значение параметра> to <конечное значение параметра> do <операторы>.

10. Оператором цикла с постусловием является:

a) Repeat <операторы> Until <условие>;

b) If <условие> Then <оператор 1> Else <оператор 2>;

c) While <условие> do <операторы>;

d) For i:=<начальное значение параметра> to <конечное значение параметра> do <операторы>.

11. Оператором цикла со счетчиком является:

a) Repeat <операторы> Until <условие>;

b) If <условие> Then <оператор 1> Else <оператор 2>;

c) While <условие> do <операторы>;

d) For i:=<начальное значение параметра> to <конечное значение параметра> do <операторы>.

12. Определите значение переменной S после выполнения программы:

Program zadacha;

Var a,b,s: integer;

Begin

а:=5;

b:=4;

if a<b Then s:=a*b Else s:=sqr(a+b);

WriteLn (s);

End.

a) 20

b) 9

c) 81

d) 400

Примечание: в данной программе sqr – это квадрат суммы.

13. Составлена программа вычисления среднего арифметического двух чисел. Определите значение переменной Sa после выполнения программы, если a=3, b=7:

Program zadacha;

Var a,b,Sa: real;

Begin

WriteLn (‘введите два числа’);

ReadLn (a,b);

Sa:=(a+b)/2;

WriteLn (Sa);

End.

a) 21

b) 5

c) 10

d) 21.5

14. Составлена программа вычисления суммы n натуральных чисел. Определите значение переменной S после выполнения программы, если n=6:

Program zadacha;

Var n,i,s: integer;

Begin

WriteLn (‘введите натуральное число’);

ReadLn (n);

s:=0;

For i:=1 to n do s:=s+i;

WriteLn (‘Сумма натуральных чисел=’,s);

End. a) 21

b) 6

c) 28d) 0

Milena251267 Milena251267    2   18.05.2020 13:10    2

Ответы
Kolodey200453 Kolodey200453  18.05.2020 13:30

ответ:1a 2b 3b 4c 5a 6a 7a 8b 9c 10c 11b 12c 13a 14c

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
polina04081 polina04081  18.05.2020 13:30
Гпааиьдшр растёшь эдеамиоллльтро
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика