Для заданного одномерного целочисленного массива mas, содержащего n произвольных положительных , отрицательных и равных нулю чисел, составить программу для вычисления: найти номер и значение последнего отрицательного числа массива. язык программирования с++

1Яблочко1 1Яблочко1    3   26.09.2019 02:50    2

Ответы
fackaF39 fackaF39  08.10.2020 19:50
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <array>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    array<int, 5> arr = { 2, -1, 5, -7, 9 };
    auto result = find_if(arr.rbegin(), arr.rend(), [](int i) { return i < 0 ? i : 0; });
    cout << *result;
}
ПОКАЗАТЬ ОТВЕТЫ
Аркаша2281337 Аркаша2281337  08.10.2020 19:50
#include "iostream"
 #include <Windows.h> 
using namespace std;
int main() { setlocale(LC_ALL, "Russian");
int n,m,index,value;
value = 0;
int mas[50];
cout << "Введите колличество элементов матрицы: ", cin >> n, cout <<endl;
for (int i = 0; i < n; i++){
cout << "Введите " << i << " элемент матрицы: ", cin >> m;
mas[i] = m;
if (m < 0) {
index = i;
 value = m;
 } 
 }
cout << "Заданная матрица: ";
for (int i = 0; i < n; i++){
  cout << mas[i] << " ";
}
cout << endl << "Номер последнего отрицательного числа: " << index << endl;
cout << "Значение последнего отрицательного числа: " << value << endl; system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика