Для заданного двумерного целочисленного массива mas, являющего квадратной матрицей размерностью n x n и содержащего n^2 произвольных положительных, отрицательных и равных нулю чисел, составить программу для вычисления: найти количество минимальных и количество максимальных чисел матрицы. язык программирования с++

angelinamikhay angelinamikhay    1   26.09.2019 02:50    1

Ответы
Witch23 Witch23  16.08.2020 22:25
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <array>
#include <iostream>
#include <algorithm>
#include <utility>
using namespace std;

int main()
{
    array<array<int, 3>, 3> arr2d { { { 5, 4, 0 },
                                      {-3, 5, 7 },
                                      { 8, 2,-1 } } };
    pair<int, int> maxmin(INT_MAX, 0);
    for (const auto& i : arr2d)
   {
        int curr_min  = *min_element(i.cbegin(), i.cend());
        int curr_max  = *max_element(i.cbegin(), i.cend());
        maxmin.first  = maxmin.first > curr_min ? curr_min : maxmin.first;
        maxmin.second = maxmin.second < curr_max ? curr_max :
maxmin.second;
    }
    cout << maxmin.first << " " << maxmin.second;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика