Для решения задать случайным образом одномерный массив размерности n (вводится с клавиатуры) из целочисленных элементов, принадлежащих отрезку [-20; 20]. вывести на экран промежуточные результаты, полученные при вычислении значения заданного выражения. составить программу для вычисления t=(r/(q+1))+s r - наименьший элемент массива; q - произведение элементов массива с нечетными номерами; s - количество элементов, лежащих в интервале (a,b) (ввести с клавиатуры).

tka4ukilia2017 tka4ukilia2017    3   11.07.2019 23:40    6

Ответы
mihajlovalena45 mihajlovalena45  07.09.2020 09:59
Var C:array[1..100] of Integer;
i,N,Q,R,A,B:integer;
T:real;
begin
Readln(N,A,B);
For i:=1 to N do
C[i]:=Random(-20,20);
R:=C[1];
Q:=1;
For i:=1 to N do
begin
If C[i]<R then
R:=C[i];
If C[i] mod 2=1 then
Q:=Q*C[i];
If (C[i]>A) and (C[i]<B) then
S:=S+1;
end;
T:=(R/(Q+1))+S;
Writeln(R,' ',Q,' ',S,' ',T);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика