Даю все свои нужно. Программа в паскале Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В по сле до ва тель но сти все гда име ет ся число, крат ное 4. Ко ли че ство чисел не пре вы ша ет 1000. Введённые числа не пре вы ша ют 30 000. Про грам ма долж на вы ве сти одно число — ко ли че ство чисел, крат ных 4.
Написал на С++
Объяснение:
#include <iostream>
#include <windows.h>//для русской раскладки
using namespace std;
int main()
{
SetConsoleCP(1251);//подключаем русскую раскладку
SetConsoleOutputCP(1251);
unsigned int kol;//количество чисел в последовательности
unsigned int kratnie4 = 0;//количество чисел кратных 4
do//проверка ввода, что количество чисел не превышает 1000
{
cout << "Введите количество чисел в последовательности (оно должно быть натуральным и меньше 1000): ";
cin >> kol;
} while (kol > 1000);
unsigned int* a = new unsigned int[kol];//инициализируем массив
cout << "Введите элементы массива(они должны быть натуральными и меньше 30000):" << endl;
for (int i = 0; i < kol; i++)
{
do//проверка ввода, что число не превышает 30000
{
cout << "a[" << i + 1 << "] = ";
cin >> a[i];
} while (a[i] > 30000);
}
for (int i = 0; i < kol; i++)
{
if (a[i] % 4 == 0)
kratnie4++;
}
cout << "Количество чисел кратных 4 в последовательности равна: " << kratnie4 << endl;
delete a; // высвобождение памяти
system("pause");
return 0;
}