Даны значения массива {аi}, i = 0, 10 и переменной х. составьте программу вычисления многочлена 10-й степени по формуле горнера: a10x10 + а9х9 + + а1х + а0 = + а9)х + а8)х + + а1)х + а0.

u95macsalinaанна u95macsalinaанна    2   28.08.2019 11:00    2

Ответы
Jakai2808 Jakai2808  20.08.2020 17:12
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

function Horner(Self:sequence of real;x:real):real; extensionmethod;
begin
  Result:=Self.Aggregate(0.0,(p,q)->p*x+q) // коэфф. по убыванию степеней!
end;

begin
  var x:=ReadReal('Укажите значение х:');
  Writeln('Введите коэффициенты в порядке возрастания степеней: ');
  Writeln('Результат: ',ReadArrReal(11).Reverse.Horner(x));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика