Даны три натуральных числа. напишите программу определяющие существукт ли треугольник с такими длинами сторон.если такой треугольник существует то определите его тип(равносторонний, равнобедренный,разносторонний)

ВадимСап ВадимСап    2   31.05.2019 18:00    7

Ответы
bogodist68 bogodist68  02.07.2020 06:17
Program u4i_div_and_mod;
var a,b,c,z,x,v:integer;
begin
readln(a,b,c);
if((a + b)> c) and ((a + c )> b) and ((c + b )> a)   then
begin
writeln('Yes');
if(a = b ) and( b = c ) then writeln('Ravnostor');
if(a = b) and (b <> c) then writeln('Ravnobedr');
if(a <> b ) and ( a <> c ) and (b <> c) then writeln('Raznost');
end
else writeln('NO');
readln;
end.
cорри за ин-яз просто кодировки разные,исправь где нужно)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика