Даны три целых числа.напишите программу ,подсчитывающую сумму тех чисел ,которые являются нечетными

14Dana14 14Dana14    2   07.09.2019 15:10    2

Ответы
ammmisha2006 ammmisha2006  06.10.2020 23:17
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Введите три целых числа:');
  var s:=0;
  if a.IsOdd then s+=a;
  if b.IsOdd then s+=b;
  if c.IsOdd then s+=c;
  Writeln('сумма нечетных равна ',s)
end.

Пример
Введите три целых числа: 345423 -324342 1231
сумма нечетных равна 346654
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика