Даны строка s и некоторые символы a и b. написать программу, определяющую, какой символ a или b встречается чаще.

ivan58888siko ivan58888siko    2   16.07.2019 14:00    4

Ответы
кВіТкА9876565446 кВіТкА9876565446  21.09.2020 10:57
Class OftenChar{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in);
  String string = in.nextLine(); char chars[] = new char[4];
  chars[0] = in.nextLine().charAt(0); chars[2] = in.nextLine().charAt(0);
  for(int sChar = 0; sChar<string.length(); sChar++)
   if(string.charAt(sChar)==chars[0])chars[1]++;
   else if(string.charAt(sChar)==chars[2])chars[3]++;
  System.out.print("\n"+(chars[1]==chars[3]?chars[0]+""+chars[2]:chars[1]>chars[3]?chars[0]:chars[2]));
 }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика