Даны два действительных числа составьте программу которая меньшее из них занимает их полусуммой а большее произведением.

Анастасия133758 Анастасия133758    1   28.08.2019 22:20    4

Ответы
mascamasa mascamasa  06.10.2020 01:35
#include <iostream>

int main() {
 double a, b, t;
 std::cin >> a >> b;
 if( a > b) {
    t = a;
    a = a * b;
    b = (t + b) / 2;
  } else {
    t = a;
    a = (a + b) / 2;
    b = t * b;
  }
  std::cout << a << " " << b << std::endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика