Даны действительные числа a,b,c. составьте программу для вычесления max (a+b,c)-min (a+c,b).

ппмв ппмв    1   06.07.2019 06:00    2

Ответы
Татьяна64101 Татьяна64101  02.10.2020 21:00
// PascalABC.Net
function max(a,b:real):real;
begin
  if a>b then max:=a else max:=b
end;

function min(a,b:real):real;
begin
  if a<b then min:=a else min:=b
end;

var
  a,b,c:real;
begin
  Write('Введите три числа через пробел: '); Read(a,b,c);
  Writeln('Результат: ',max(a+b,c)-min(a+c,b))
end.

Тестовое решение:
Введите три числа через пробел: 5 -2 3.8
Результат: 5.8
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика