Даны целые числа x и y. написать программу определения знака разности x-y. разность вычислять нельзя. разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.

Dinomyron Dinomyron    3   02.06.2019 05:20    14

Ответы
двоишник55 двоишник55  03.07.2020 01:26
Program raznost_xy;
var x, y:integer;
begin
write ('Введите число х = ');
readln (x);
write ('Введите число у = ');
readln (y);

if (x>0) and (y>0) then
  begin
    if abs(x)>abs(y) then write ('x-y > 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y < 0');
  end;
      
if (x<0) and (y<0) then
  begin
    if abs(x)>abs(y) then write ('x-y < 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y > 0');
  end;

if (x=0) and (y=0) then write ('x-y = 0');
if (x>0) and (y<0) then write ('x-y > 0');
if (x<0) and (y>0) then write ('x-y < 0');
if (x=0) and (y>0) then write ('x-y < 0');
if (x=0) and (y<0) then write ('x-y > 0');
if (x>0) and (y=0) then write ('x-y > 0');
if (x<0) and (y=0) then write ('x-y < 0');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика