tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Даны целое число n и массив
Даны целое число n и массив чисел а1, а2, … аn. получить из массива а массив b, для которого b1=a1, bn= аn, а начиная со второго элемента bi=ai+аi+1.
nastya200525
3 27.07.2019 23:20
2
Ответы
даззвдклкоеллсдвжуэ
25.09.2020 14:51
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var n:=ReadInteger('n=');
var a:=ArrRandom(n,10,40); a.Println;
var b:=a.Select(e->2*e+1).ToArray;
b[0]:=a[0]; b[n-1]:=a[n-1];
b.Println
end.
Тестовое решение
n= 10
16 11 28 30 20 39 12 27 12 31
16 23 57 61 41 79 25 55 25 31
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Mesnikfff
13.07.2019 10:20
1. клавиатура - это a) устройство ввода символьной информации b) устройство для связи компьютеров через телефонную сеть c) устройство для облегчения работы с экраном...
неизвестенине
13.07.2019 10:20
Напишите процедуру, которая выводит на экран фразу я люблю паскаль заданное в ее параметре количество раз...
dv1ne
10.09.2020 00:10
Word 5. Какими можно создать список для выделенного текста? - 6. Можно ли изменить маркер в уже созданном списке? 7. Как удалить список?...
hiohio
10.09.2020 00:57
Какие виды информации являются главными для того или иного животного или растения?...
vikasibarik
10.09.2020 00:54
Запишите в постфиксной форме запись числа...
ijrts
30.04.2020 08:33
Определи, какие из файлов сжимаются лучше всего.monitor.bmpletter.docxlettercolor.mscolormonitor. ...
paliy2006
30.04.2020 08:33
Укажите Входные данные программы *...
оооооченьТупой
30.04.2020 08:33
Цель проектирования программы *...
superasmik2018
30.04.2020 08:32
Дана программа:Program Primer;VarN,result : real;Begin Writeln( Введите значения переменной N ); Write( N= ); Readln(N); Result := sqr((2+N)*5); Writeln ( sqr((2+N)*5)...
ева470
22.12.2020 06:34
Вариант 2 Выберите из предложенных величин логическую величину. 1 TRUE ‘да’ 146.3 0.25 Переведите арифметические выражения из линейной записи в общепринятую. а) a +...
Популярные вопросы
Какие вы знаете экологические факторы?...
1
Что такое стимул? Какова его роль в коммуникации между животными...
2
Рассмотрите рисунок 281. На нем изображен стаю павианов. Опишите...
3
Могут ли животные понимать язык человека? Какие исследования были...
3
О чем свидетельствуют «танцы» пчел?...
1
Какое значение демонстрации угроз?...
2
Как успокаивающее поведение предотвращает агрессии?...
2
Пользуясь различными источниками информации, подготовьте мини-проект...
2
Как вы считаете, почему кошка тратит гораздо больше времени на вылизывание...
2
Как различные формы поведения животным при к условиям среды?...
2
begin
var n:=ReadInteger('n=');
var a:=ArrRandom(n,10,40); a.Println;
var b:=a.Select(e->2*e+1).ToArray;
b[0]:=a[0]; b[n-1]:=a[n-1];
b.Println
end.
Тестовое решение
n= 10
16 11 28 30 20 39 12 27 12 31
16 23 57 61 41 79 25 55 25 31