Дано некоторое число составьте программу которая выводит какое это число положительное или отрицательное если оно положительное уменьшить в 2 раза а в другом случае взвести в квадрат.

Kseniamaria Kseniamaria    1   19.07.2019 18:20    1

Ответы
Имра11111 Имра11111  03.10.2020 08:06
//Pascal ABC.NET v3.1 сборка 1172

Var
 a:real;
begin
 readln(a);
 if a>0 then writeln('Положительное, ',a/2) else
  if a<0 then writeln('Отрицательное, ',sqr(a)) else
   writeln('0');
end.

Пример ввода:
-12
Пример вывода:
-, 144
ПОКАЗАТЬ ОТВЕТЫ
sibuna1 sibuna1  03.10.2020 08:06
По моему такая задача уже несколько раз была здесь.
//Pascal
var a:integer;
begin
  readln(a);
  if a>0 then writeln('Положительное ', a/2)
     else
         if a<0 then writeln('Отрицательное', a*a);
  if a=0 then writeln('0 - не положительное и не отрицательное число');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика