Дано натуральное трёхзначное число. Напишите программу, которая определяет, есть ли среди цифр данного числа одинаковые. ​


Дано натуральное трёхзначное число. Напишите программу, которая определяет, есть ли среди цифр данно

Ro4KKy Ro4KKy    3   19.05.2021 00:00    6

Ответы
mysenjor mysenjor  18.06.2021 03:45

var

  n,r1,r2,r3,r4 : integer;

begin

  readln(n);

  r1:=n mod 10; r2:=n div 10;

  r3:=r2 mod 10; r4:=r2 div 10;

  if (r1 = r3) or (r1 = r4) then

     writeln('Да')

  else

     writeln('No');

end.

ПОКАЗАТЬ ОТВЕТЫ
nazyrovailnara nazyrovailnara  18.06.2021 03:45

Паскаль

var d,x,y,z:integer;

begin

writeln ('Введите трехзначное число');

readln (d);

x:=d mod 10;

y:=d div 10 mod 10;

z:=d div 100 mod 10;

if (x=y) or (x=z) or (y=z) then writeln ('Да')

else writeln ('Нет');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика