Дано натуральное число n. написать программу, выводящую последовательность чисел 1,2, (решить с while) по возможности решите еще и дано n натуральных чисел. написать программу, вычисляющую их среднее арифметическое (число n вводится перед всеми остальными числами ) дано натуральное число n. написать программу, выводящую степени двойки от первой до n-й 2,4,8,6

бах8 бах8    1   25.06.2019 00:30    1

Ответы
ulaborodina57 ulaborodina57  02.10.2020 10:51
Var n,i:integer;
begin
write('N= ');
read(n);
i:=1;
while i<=n do
begin
writeln(i);
i:=i+1;
end;
end.

var n,i,sum:integer;
cp:real;
begin
write('N= ');
read(n);
i:=0;
while i<n do
begin
i:=i+1;
sum:=sum+i;
end;
cp:=sum/i;
writeln('Среднее значение натуральных чисел до N равно ',cp);
end.

var n,i,b,m:integer;
begin
write('N= ');
read(n);
b:=2;
i:=0;
write(b);
writeln;
while i<n-1 do
begin
i:=i+1;
b:=b*2;
writeln(b);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика