Дано натуральное число m. написать программу для вычисления суммы вида: 45+42+39++m. входные данные n=38 выходные данные 126

Olga5513 Olga5513    2   20.05.2019 19:25    10

Ответы
marisshechka1 marisshechka1  14.06.2020 11:46

Begin

Read(a);

Sum:=45;

I:=45;

While i>a do

Begin

I:=i-3;

Sum:=sum+i;

End;

Write(sum);

End.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
MariyamGaraeva MariyamGaraeva  14.06.2020 11:46

Ну, вот на Pascal написал. Вроде так...

var  

Sum, I : integer;

Sum := 0;

I := 45;

While I >= M do

begin

Sum := Sum + I;

I := I - 3;

end;

Writeln(Sum);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика